Adattatori wireless DLink DWA-140 e Ubuntu 11.04 o precedente

I driver per i dispositivi DLink con chipset ralink sono integrati in Ubuntu. Tuttavia questi driver entrano in conflitto con altri driver e quindi il sistema non riesce a caricarli correttamente (nella nuovissima versione 11.10 il problema è stato risolto, quindi se vi secca smanettare, non dovrete far altro che aggiornare la vostra distribuzione).

Perchè vengano caricati correttamente, è quindi necessario dire al sistema di non caricare i driver che vanno in conflitto con quelli che ci servono. Per farlo, create e riempite il file /etc/modprobe.d/blacklist-rt2870.conf.

sudo gedit /etc/modprobe.d/blacklist-rt2870.conf

E aggiunteci all’interno le seguenti righe:

blacklist rt2800usb
blacklist rt2x00usb
blacklist rt2x00lib

Se preferite potete aggiungere le righe precedenti direttamente all’interno del file /etc/modprobe.d/blacklist.conf.

Adesso non dovete far altro che riavviare il sistema. Buona navigazione wireless.